Runs great when your in the gas, when you come off throttle it dies.

  • This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Vasilios

Active Member
Aug 14, 2013
#1
I haven't had any issues so far up until yesterday, running hard it runs great, when you let off the throttle it backfires, spits sputters, and dies. It starts right back up no problem. Any ideas on what could be the issue, I am thinking one of the jets is clogged with dirt or something. It probably just needs a good cleaning. This happened all of a sudden. The quad had no issues prior to this. 2013 450r. Any ideas would be greatly appreciated.
 

OTMTRX

Active Member
Apr 9, 2012
#2
I'd start with the carb for sure, clean out your tank too.. maybe got moisture / water in from somewhere.. good carb clean / remove n check all jets / good blow-out then some fresh gas in a clean tank..
 

Vasilios

Active Member
Aug 14, 2013
#8
Carb was clean. Water in the bowl. Drained it out cleaned it anyway and she runs great. I tore the whole thing down it looks brand new. I also pulled the plug and looked in the cylinder with a bore scope. It got a little steam cleaning. Everything looks good. Time to tear it up. The new shocks are amazing (axis ) front and rear long travel.
 

Vasilios

Active Member
Aug 14, 2013
#12
Yeah it was pinned in there, I pulled that out with a pair of talon grip needle nose that snap on makes. They work awesome. I took out the fuel screw and replaced it with a flex jet, so it's easy to make adjustments. Everything was fine on the carb end of things. I put one of those stubby vent tubes on with the check ball in it, and the ball jammed, so I had no vent. I fixed that problem, but I'm going back to the normal vent tube, as soon as I get to the local shop In the morning. I think somebody warned me about those things on the org. I'm going to call this a learning experience. Oops